System Requirements


PowerBASIC product(s) are 32 bit applications and are compatible with 64 bit versions of Windows.

A minimum of Windows 2000 is required to install our product(s). A complete install of all PowerBASIC products takes less than 250 MB of hard drive space.

Most computers in current use will have no trouble running PowerBASIC product(s).

While Windows 2000 is required to install our product(s) – care can still be taken to create applications that will work on versions of Windows prior to Windows 2000 if that is needed. If this is needed, we recommend you use PB/WIN version 8 or 9, or PB/CC version 4 or 5 depending on that need. The older versions will make it easier to create applications that are compatible.

While the license agreement does allow transfer of our applications to another computer, as long as there is no possibility of it being used on more than one computer at the same time, it is not recommended to try and run any of the development tools, such as the IDE or PB/Forms on operating systems older than Windows 2000. All product(s) available have been updated to use HTML Help instead of WinHelp. As well, some functions of the IDE in PBWIN 10 / PBCC 6 simply will not work on Win9x.

PowerTREE - once installed will execute properly on Windows 95-Windows 10.

On an older computer, if you have megabytes upon megabytes of source code that you’re opening all at the same time, it is possible for system resources to be limited. The likelihood of encountering such an issue is low.

With a single source code file open in PB/WIN 10 that is approximately 15,000 lines long and 677 KB in size, the IDE only uses 25 MB of RAM.